Installation issue connecting to MSSQL db

We’re running into a database connection issue when installing the software. The database server we are using is called “BLINKBD01\Bluelink” with IP 192.168.161.120. In SQL Server Management Studio we can connect to the database using the IP address but it requires the “\Bluelink” to connect (e.g. 192.168.161.120\Bluelink) and we can connect with the full name BLINKDB01\Bluelink.

If we use 192.168.161.120\Bluelink, the Agiloft installation returns “unkown server host name” error. If we just use the IP, it gives the error “Connection refused”. If we use the server name, it also returns “unkown server host name”. The SQL account we’re using has sysadmin privileges. We’ve completed the DTC configuration on the server, placed the sqljdbc_xa.dll in the BINN folder in the SQL folder and run the 2 sql scripts (aluser.sql and xa_install.sql).

Have you guys seen this before? Is it because we have a compound server name (\Bluelink)?

If you specify the port number, then you don’t need to specify the Instance name, because no two instances can share the same port. Please test the connection from the command line using the SQLCMD utility.

To connect using port number follow the general syntax:
sqlcmd.exe -S tcp:<computer name>,<port number> -Q "select getdate()"

To connect using a named instance follow the general syntax:
sqlcmd.exe -S tcp:<computer name>\<instance name> -Q "select getdate()"

If TCP/IP is not enabled for the MS SQL instance, then please follow the instructions at https://technet.microsoft.com/en-us/library/hh231672(v=sql.110).aspx to enable it.